аянаайши
26.04.2022 04:39

Кто разбирается? короче, такая хрень, ! составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми знаниями; б) находит индексы нечетных элементов; в) подсчитывает количество положительных элементов. -ну? кто тут умный?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aruzhaan2003
04.10.2020 12:34
На каком языке программирования?

Паскаль АБС

var
i,count:integer;
a:array [1..16] of integer;
begin
for i:=1 to 16 do begin
a[i]:= Random (-20,20);
end;
for i:=1 to 16 do begin
if (a[i] = 0) then
writeln ('Нулевой элемент ',a [i]);
if (a [i] mod 2 = 1) then
writeln ('Индекс нечетного элемента ',i);
if (a [i] >0) then
inc (count);
end;
writeln ('Количество положительных чисел ',count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота