eaglez91Aidana
23.03.2020 03:01

1)составить программу для поиска наибольшего из 4 чисел. 2) cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны. только плз чтобы там было типо такого : var a,b,c,d max: integer

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Cool4man
04.10.2020 13:39
1)
var
  a, b, c, d, max: integer;
 begin
  readln(a, b, c, d);
  if(a > b) and (a > c) and (a > d) then max := a
  else if(b > a) and (b > c) and (b > d) then max := b
  else if(c > a) and (c > b) and (c > d) then max := c
  else max := d;
  write(max);
end.
2)
var
a, b, c, max:
integer;
 begin
  readln(a, b, c);
  if(a > b) and (a > c) then max := a
  else if(b > a) and (b > c) then max := b
  else max := c;
  write(max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота