renatadautova
15.11.2020 23:37

Составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastiia4
02.08.2020 15:24
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        static void Main(string[] args)
        {
            bool result = false;
            Console.WriteLine("Введи строку");
            string str = Console.ReadLine();
            for (int i = 0; i < str.Length - 1; i++)
            {
                if (str.Substring(i, 1) == str.Substring(i + 1, 1))
                {
                    result = true;
                    break;
                }
            }

            if (result == true)
                Console.WriteLine("Да, встречаются");
            else
                Console.WriteLine("Нет, не встречаются");

            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота