fomicheva3ket
01.01.2023 22:17

Заполнить массив (а) случайными целыми числами разных знаков. составить программу вывода на экран номеров элементов массива, равных максимальному. надо.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dash528
04.10.2020 18:48
Const n=10;
var a:array[1..n] of integer;
max,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
 a[i]:=random(21)-10;
 write(a[i],' ');
 end;
writeln;
max:=a[1];
for i:=2 to n do
 if a[i]>max then max:=a[i];
writeln('max = ',max);
for i:=1 to n do
 if a[i]=max then write(i:3);
writeln;
end.

Пример:
Исходный массив:
-6 -9 10 -6 0 0 -8 10 -8 2 
max = 10
  3  8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота