немагистор
07.05.2023 23:49

Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
wikkouiii
02.08.2020 16:51
Не понял смысл задачи. 
Написал, вывод номера элементов равных 0.
Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находи
0,0(0 оценок)
Ответ:
мирали3
02.08.2020 16:51
#include <stdio.h>#include<stdlib.h>
int main(void){    int mas[16]; //массив со случайными числами    int i; //счетчик
    //заполнение массива случайными числами    for(i=0; i<16; i++)    mas[i] = -20+rand()%20;    printf("ishodny massiv");    for(i=0;i<16;i++)        printf("%d,",mas[i]);    printf("\n");
    printf("nomera elementov massiva ravnih nulu");    for(i=0;i<16;i++)    if (mas[i]==0) printf("%d",i+1);
return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота