trunczova84
19.03.2020 08:31

Написать программу, которая вводит массив из 8 целых чисел и выводит на экран элементы с четными номерами

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tttttrrr
04.10.2020 21:17

Program zadacha1;
uses crt;
const N=5;  //размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Прямой вывод');
For i:=1 to n do
writeln(m[i]);
Writeln('Обратный вывод');
For i:=1 to n do
writeln(m[n+1-i]);
End.

 

Program zadacha2;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if i mod 2 = 0 then writeln(m[i]);
End.

 

Program zadacha3;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if (n+1-i) mod 2 <> 0 then writeln(m[n+1-i]);
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота