veronikamihailova37
02.04.2020 14:59

Уровень а. (оценка 3). напишите программу, которая выводит m линий из символа s, заданного пользователем длиной n символов. при запуске программы m, n, s нужно ввести с клавиатуры. пример: количество линий: 2. длина цепочки: 7. символ-заполнитель: - для реализации программы напишите процедуру line, которая принимает два параметра – символ-заполнитель s и натуральное число n, и выводит на экран одну линию из символов s длиной n. пример: длина цепочки: 7. символ-заполнитель: -

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ermolenkoo
05.10.2020 01:31
//PascalABC.NET 3.2 сборка 1318

Var
  m,n,i:integer;
  s:char;

procedure line(c:char;n:integer);
Var
  i:integer;
begin
for i:=1 to n do
write(c);
writeln;
end;
 

begin
readln(m,n);
readln(s);
for i:=1 to m do
line(s,n);
end.

Пример ввода:
2
7
-
Пример вывода:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота