киса822
30.03.2020 01:45

Напишите на паскале. : написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом r

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zenix122
05.10.2020 03:13
Var a,b,c,r,s,p: real;
begin
  write('длины сторон треугольника a,b,c через пробел: ');
  readln(a,b,c);
  write('радиус круга r: ');  readln(r);
  p:=(a+b+c)/2;
  s:=sqrt(p*(p-a)*(p-b)*(p-c));
  if r>=(a*b*c)/(4*s) then writeln('можно поместить')
  else writeln('нельзя поместить');
end.

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота