ppp13
28.09.2022 22:21

1. напишите программу, которая из пяти введенных с клавиатуры натуральных чисел определяет максимальное число, кратное 2. 2.напишите программу, которая в последовательности пяти натуральных чисел, введенных с клавиатуры определяет сумму чисел, кратных 2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastiaprokopiv
08.09.2020 19:20
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

Задача №1

begin
  var s:=ReadArrInteger(5).Where(x->x.IsEven);
  if s.Count>0 then Writeln(s.Max)
  else Writeln('Четных элементов нет')
end.

Задача №2 (делается из (1) путем замены трех символов)

begin
  var s:=ReadArrInteger(5).Where(x->x.IsEven);
  if s.Count>0 then Writeln(s.Sum)
  else Writeln('Четных элементов нет')
end.
0,0(0 оценок)
Ответ:
Nazar0905
08.09.2020 19:20
1)
#include <iostream>

using namespace std;

int main() {
  int max = INT32_MIN;
  for(int i = 0; i < 5; i++) {
    int number;
    cin >> number;
    if(number % 2 == 0 && number > max) max = number;
  }
  if(max != INT32_MIN) cout << max << endl;
  else cout << "no such numbers" << endl;
}

2)
 #include <iostream>

using namespace std;

int main() {
  int s = 0;
  for(int i = 0; i < 5; i++) {
    int number;
    cin >> number;
    if(number % 2 == 0) s+=number;
  }
  cout << s << endl;
}

язык C++
      
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота