livekristinka
07.08.2021 06:19

Pascal составить программу поиска трех значных чисел, сумма цифр которого равна n

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Викитирон
08.09.2020 19:57
Var
  i, n, s, k: integer;
begin
  readln(n);
  for i := 100 to 999 do
  begin
     s := 0; k := i;
     while  k > 0 do
     begin
        s := s + k mod 10;
        k := k div 10;
     end;
     if s = n then
        writeln(i);
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота