Аркадий111111122222
29.06.2022 01:59

1)составить программу, определяющую на какую букву заканчивается предложение. 2) определить длину 2 слова в предложении

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
v1k2
24.04.2020 04:00
Var s: string;
    k: integer;
begin
  write('строка: ');  readln(s);
  writeln('строка заканчивается на букву ','"',s[length(s)],'"');
  k:=pos(' ',s);
  if k=0 then 
  begin
    writeln('в строке одно слово');
    exit;
  end;
  delete(s,1,k);
  k:=pos(' ',s);
  write('длина второго слова: ');
  if k=0 then writeln(length(s))
  else writeln(k-1);
end.

строка: это строка для проверки
строка заканчивается на букву "и"
длина второго слова: 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота