Приветусик11
28.07.2021 13:53

Составьте программу которая в массиве a из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vb8515401
14.08.2020 17:18
Лови)

const
  k = 20;

var
  A: array [1..k] of real;
  i: integer;
  min, average: real;

begin
  writeln('Enter x:');
  for i := 1 to k do
  begin
    A[i] := random(k);
    writeln('A[', i, '] = ', A[i]);
  end;
 
  min := A[i];
  average := 0;
  for i := 1 to k do
  begin
    average := average + A[i] / k;
    if min > A[i] then
      min := A[i];
  end;
 
  writeln(min * average);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота