Vladimirtty
04.10.2020 05:51

Составьте программу в паскале заполнить массив а пятью произвольными целыми числами. изменить каждый элемент массива так, чтобы он был умножен на свой порядковый номер. исходный и полученный массив вывести на экран. пример: исходный массив: 2 6 8 9 12 полученный массив: 2 12 24 36 60

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
huifufjvJf
05.10.2020 07:49
Для случайных чисел:

var
   a: array[1..5] of integer;
   i: integer;
begin
   randomize;
   for i:=1 to 5 do
      a[i] := random(100);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.

Для ручного заполнения:

var
   a: array[1..5] of integer;
   i: integer;
begin
   for i:=1 to 5 do
      readln(a[i]);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота