Vikusyadubenko
24.05.2022 06:26

Составить программу , которая вычесляет произведение сумму первых 137 натуральных чесел (параметром цикла является переменная а, а произведение хранится в переменой p) решите я на уроке !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mihailodnowal777
09.08.2020 16:26
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p:=Range(1,137);
  Writeln('Сумма чисел от 1 до 137 равна ',p.Sum);
  Writeln('Их произведение равно ',p.Aggregate(BigInteger(1),(x,y)->x*y))
end.

Результат
Сумма чисел от 1 до 137 равна 9453
Их произведение равно 5012888748274991661034926292112253883237205694398754483388962668892510972746226260034675717797072343372830591567227826571884373881355612819314826377917827129740056802397016509378163883274055583382110208000000000000000000000000000000000
0,0(0 оценок)
Ответ:
pernik20121
09.08.2020 16:26
Var a,p:integer;
begin
p:=1;
for a:=1 to 137 do p:=p*a;
writeln(p);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота