суроккк
27.05.2023 08:30

Напишите программу, которая вычисляет факториал натурального числа n ( 1 ≤ n ≤ 10000 ), сохранив все значащие цифры. факториалом называется произведение всех натуральных чисел от 1 до n : n ! = 1·2· ( n - 1)· n .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nazyrovailnara
05.10.2020 10:12
Program n1;
var
n, i: integer;
p: real;
begin
write('Введите n: ');
readln(n);
if (n>=1) and (n<=10000) then
begin
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ', p);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота