galinaegi2
06.08.2021 16:31

Написать программу, которая получает на вход число произвольной длины меньше, чем 9 знаков и показывает, какие в нем повторяющиеся цифры быстрее! 11! мог не правильно понять вопрос, напишите хоть что-нибудь похожее , нужно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kill111111111111
05.10.2020 11:42
var i,n,k: integer;
    a: array[0..9] of integer;
begin
  write('число: ');  readln(n);
  for i:=0 to 9 do a[i]:=0;
  while n>0 do
  begin
    k:=n mod 10;
    a[k]:=a[k]+1;     
    n:=n div 10;
  end;  
  for i:=0 to 9 do 
  if a[i]>1 then writeln('повторяющаяся цифра: ',i);
end.

число: 1022315
повторяющаяся цифра: 1
повторяющаяся цифра: 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота