madina123452
28.02.2021 10:37

Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vladislav553
05.10.2020 13:16
# coding: utf-8

'''
Последовательность состоит
из натуральных чисел и завершается
числом 0. Определите, сколько
элементов этой последовательности
больше предыдущего элемента.

Python 3.X.
'''

prev = int(input()) # ввод первого элемента
count = 0 # изначально 0 элементов

while True:
    n = int(input()) # ввод числа
    if n == 0:
        break # выход, если 0
    if n > prev:
        count += 1
    prev = n # смещение числа

print(count, "эл.")
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота