verahohlova
01.03.2020 12:55

Даны два целых числа a и b. напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b входные данные: в первой строке вводятся два целых числа a и b (a< =b, a,b не больше 100 по модулю) выходные данные: программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой) в c++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lera111katy
31.08.2020 20:49
#include <iostream>

using namespace std;

int main()
{
    int a,b,n = 0;
    float S = 0;
    cin >> a;
    cin >> b;
    
    for(int i = a; i <= b; i++)
    {
         n++;
         S+=i*i;
    }
    S = S/n;
    cout.setf(ios::fixed);
    cout.precision(2);
    cout << "S = " << S << endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота