partybally
06.05.2023 12:06

Написать программу в free pascal'e,! условие: пусть k - целое от 1 до 365. присвоить целой переменной n значение 1, 2, 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alinkaaa888
05.10.2020 20:07
Var k,n:integer;
begin
write('k = ');
readln(k);
n:=(k-1) mod 7+1;
writeln('n = ',n);
end.

Пример:
k = 21
n = 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота