HappyGamerPro
19.06.2022 07:37

Напишите программу в паскаль, в одномерном массиве из 10 элементов вычислить произведение чётных и сумму нечётных.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hiohio
03.08.2020 08:58
Program z1;
var a:array[1..10] of integer; i:integer; s,p:longint;
begin
p:=1;
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
if a[i] mod 2 = 0 then p:=p*a[i] else s:=s+a[i];
write('произведение четных = ',p,' сумма нечетных = ',s);
end.
0,0(0 оценок)
Ответ:
Nik0name1
03.08.2020 08:58
// PascalABC.NET 3.2, сборка 1404 от 16.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-99,99); a.Println;
  Writeln('Сумма элементов с четным значением ',
      a.Where(x->x.IsEven).Sum);
  Writeln('Произведение элементов с нечетным значением ',
      a.Where(x->x.IsOdd).Aggregate(int64(1),(x,y)->x*y))
end.

Пример
45 -95 41 -26 -99 -96 77 -4 18 41
Сумма элементов с четным значением -108
Произведение элементов с нечетным значением 54780974325
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота