farkhundaibragimova
11.04.2022 18:21

Программа получает на вход целые числа, не равные 0. количество введенных чисел неизвестно, последовательность чисел заканчивается 0. введенные числа по модулю не превышают 30000. программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Anastasiya3434
05.10.2020 22:09
Var A,Max,Min:integer;
Begin
ReadLn(A);
Max:=A;
Min:=A;
While A<>0 do
   Begin
   ReadLn(A);
   if A>Max then Max:=A;
   if A<Min then Min:=A;
   End;
WriteLn(Max/Min > 2)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота