nikitaaleksandrov
21.08.2022 12:22

Дан массив из 30 произвольных элементов, каждый из которых не больше 100. найдите максимальный элемент кратный 9.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ola124
05.10.2020 22:52
Const
   N = 30;
Var
   A:array[1..N] of byte;
   i,Max:integer;
Begin
Max:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(101);
    if (A[i] mod 9 = 0)and(A[i] > Max) then Max:=A[i];
    Write(A[i],' ');
    End;
WriteLn;
if Max = 0 then WriteLn('В массиве нет элементов, кратных 9')
else WriteLn('Max = ',Max)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота