555gm
12.03.2021 19:57

Нужно, составьте программу на языке паскаль для нахождения радиуса описанной окружности вокруг треугольника, если известны стороны треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Ответ:
пантера49
06.10.2020 00:49
Var
   a,b,c,p:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if (a<b+c)and(b<c+a)and(c<a+b) then
   Begin
   p:=(a+b+c)/2;
   WriteLn('R = ',a*b*c/Sqrt(p*(p-a)*(p-b)*(p-c)));
   End
else WriteLn('Треугольник не существует')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота