Lady2575
20.09.2020 08:28

Напишите программу в дельфи которая переводит число из десятичной в факториальную систему счисления.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sherlokzn
06.10.2020 02:09
Консольное приложение:
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
 begin
 i:=i+1;
 str(k mod i,m);
 f:=m+f;
 k:= k div i;
 end;
writeln('f = ',f);
end.

Пример:
n = 100
f = 4020
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота