СилаЛебедя
18.02.2023 08:33

Написать программу в паскале. дан массив размера n. массив отсортировать в порядке возрастания. для отладки программы числа последовательностей сформировать с генератора случайных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
znaniyasveta
06.10.2020 03:51
Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,j,Min,B:integer;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(2*N+1)-N;
    Write(' ',A[i])
    End;
WriteLn;
Write('Отсортированный массив:');
For i:= 1 to N do
    Begin
    Min:=i;
    For j:= i+1 to N do
        if A[j] < A[Min] then Min:=j;
    B:=A[i];
    A[i]:=A[Min];
    A[Min]:=B;
    Write(' ',A[i])
    End;
ReadLn
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота