erisoeun
13.11.2022 10:00

Составьте программу получения в порядке убывания всех делителей данного числа n. число n вводится с клавиатуры. .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
cfxdcvbnm
06.10.2020 04:23
Var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители числа ',n,':');
for i:=n div 2 downto 1 do
 if n mod i=0 then write(i,' ');
end.

Пример:
n = 24
Делители числа 24:
12 8 6 4 3 2 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота