Чай24
01.02.2023 04:08

Напишите программу сложения, вычитания и умножения двух двоичных чисел. предложите проверки результата: 1011 и 110

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
астра1603
06.10.2020 07:01
Const
  Rn : String[36] = '0123456789';

Function DecToN(a : Longint; Raz : Byte) : String;
Begin
  If a>Raz-1 then DecToN:=DecToN(a div Raz,Raz)+Rn[(a mod Raz)+1]
  else DecToN:=Rn[a+1];
end;

Function NToDec(a : String; Raz : Byte) : Longint;
Begin
  If Length(a)>0 then NToDec:=Pos(a[Length(a)],Rn)-1+Raz*NToDec(Copy(a,1,Length(a)-1),Raz)
  else NToDec:=0;
end;

Var a,b : String;
Begin
  a:='1011'; b:='110';
  Writeln('a = ',a,' (bin) = ',NToDec(a,2),' (dec)');
  Writeln('b = ',b,' (bin) = ',NToDec(b,2),' (dec)');
  Writeln(a+'+'+b+' = ',DecToN(NToDec(a,2)+NToDec(b,2),2),' (bin)  ',NToDec(a,2)+NToDec(b,2),' (dec)');
  Writeln(a+'-'+b+' = ',DecToN(NToDec(a,2)-NToDec(b,2),2),' (bin)  ',NToDec(a,2)-NToDec(b,2),' (dec)');
  Writeln(a+'*'+b+' = ',DecToN(NToDec(a,2)*NToDec(b,2),2),' (bin)  ',NToDec(a,2)*NToDec(b,2),' (dec)');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота