anelyasabina20
01.10.2020 18:40

Напишите программу на языке pascal дано: натуральное число -n выяснить с цикла repeat является ли оно простым (то есть делится на 1 и на само себя)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
janeair6994
06.10.2020 08:01
Var
  i, n: integer;
 
begin
  i := 1;
  read(n);
  repeat
    i := i + 1;
    if(n mod i = 0) and (n <> i) or (n = 1) then
      begin
       write('Число ', n, ' не является простым');
       exit;
      end;
  until i = trunc(sqrt(n)) + 1;
  write('Число ', n, ' является простым');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота