vika8330
03.10.2020 12:39

Напишите программу,которая для заданной последовательности натуральных чисел подсчитывает сумму входящих в неё трехзначных чисел,которые делятся на 7.программа получает на вход кол-во чисел в прследовательности, а затем сами числа.кол-во чисел не превышает 1000.введенные числа не превышают 30 000.программа должна вести одно число-сумму трехзначных чисел,находящихся в заданной последовательности натуральных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Cociheyuajnqhvedoxbs
06.10.2020 10:27
Program hhh54;
var n,x,i,s: longint;
begin
  s:=0;
  read (n);
  for i:=1 to n do;
    begin
      read (x);
      if (x > 99) and (x < 1000) and (x mod 7 = 0) then s:=s+x;
    end;
  write (s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота