почмат
08.04.2022 19:49

Написать программу, которая запрашивает номер дня недели и выводит его название. включить в программу модуль crt. запрос и результат работы программы вывести в окнах разного цвета. установить цвет символов по желанию. pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ValeriaAstahova99
06.10.2020 11:30
Uses Crt;

Procedure R(Nazvanie:string; Cvet:byte);
Begin
TextBackground(Cvet);
ClrScr;
GotoXY(WindowWidth div 2-Length(Nazvanie) div 2,WindowHeight div 2);
Write(Nazvanie);
End;

Var n:byte;
Begin
HideCursor;
TextBackground(0);
ClrScr;
TextColor(15);
GotoXY(WindowWidth div 2-12,WindowHeight div 2);
Write('Введите номер дня недели');
Case ReadKey of
'1':
    R('Понедельник',4);
'2':
    R('Вторник',14);
'3':
    R('Среда',2);
'4':
    R('Четверг',9);
'5':
    R('Пятница',1);
'6':
    R('Суббота',13);
'7':
    R('Воскресенье',12);
else R('В неделе сейчас семь дней!',0);
End;
ReadKey
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота