strume54
03.11.2021 04:44

Составить программу формирования массива а из n случайных вещественных чисел, сделать возможным его редактирование. вычислить сумму дробных частей положительных элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Afakado
06.10.2020 12:16
{$APPTYPE CONSOLE}
Const
   N = 13;
Var
   A:array[1..N] of real;
   i,C:integer;
Procedure ZAPOLNENIERND();
Var i,j:integer;
Begin
Randomize;
For i:= 1 to N do
    A[i]:=random*21-10;
End;

Procedure BbIBOD();
Var i,j:integer;
Begin
For i:= 1 to n do
    Write(A[i]:4:1,' ');
WriteLn;
End;

Procedure RE();
Begin
Write('i = ');ReadLn(i);
Write('A[',i,'] = ');ReadLn(A[i]);
End;

Procedure SF();
Var
   i:integer;
   S:real;
Begin
S:=0;
For i:= 1 to n do
    if A[i] > 0 then S:=S+Frac(A[i]);
WriteLn('S = ',S);
End;

Begin
ZAPOLNENIERND();
BbIBOD();
Repeat
WriteLn;
WriteLn('1 - заполнить массив случайными числами');
WriteLn('2 - ввести новое значение заданного элемента');
WriteLn('3 - вычислить сумму дробных частей положительных элементов массива. ');
WriteLn('4 - вывод массива');
WriteLn('9 - выход');
ReadLn(C);
Case C of
1:
  Begin
  ZAPOLNENIERND;
  BbIBOD;
  End;
2:RE;
3:
  Begin
  SF();
  End;
4:BbIBOD;
End
Until C = 9;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота