MOJH
05.01.2021 08:46

Напишите программу, которая заполняет массив из 20 элементов натуральными числами и считает разность произведений четных и нечетных элементов массива(paskal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
БПД
06.10.2020 12:25
var 
b: array[1..20] of BigInteger; 
pr, pr1, raz: BigInteger;

begin 
pr := 1; 
pr1 := 1; 
for var i := 1 to 20 do 
begin   
b[i] := random(100) + 10;   
write(b[i]+' ');   
if b[i] mod 2 = 0 then      
pr := pr * b[i];   
if b[i] mod 2 <> 0 then      
pr1 := pr1 * b[i];   
raz := pr - pr1; 
end; 
writeln(); 
writeln('Разница равна ', raz);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота