Войти
Регистрация
Спроси ai-bota
dilnoza2006
04.03.2022 18:05
Написать программу построения графика функции в графическом режиме.y=cos(x^2). pascal.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
yyyye
27.04.2022 07:16
Якщо значення змінноїх дорівнює 10, ви«Pascal».2. Довжина сторони квадрата а, радіус колПрактична роботаСкладання та виконання алгоритмів з роз“нання алгоритмів з розгалуженнямвести...
tamirisis7sk
19.06.2022 21:30
Составить блок схему алгоритма для решения следующей задачи:Известно,что плата за питание в школе за месяц составляет 1500 рублей (22 дня).Расчитать,сколько нужно заплатить за месяц,если...
efrdariya14
04.10.2022 08:46
Переведите число 301в10 в двоичную, восьмеричную и шестнадцатеричную систему счисления...
mickeymouse1958
15.11.2021 20:26
Составить блок схему алгоритма для решения следующей задачи. Дана сумма начисленной заработной платы, вычислить подоходный налог 12%,1% на профсоюзный налог 1%, на пенсионный налог....
azatnacu
25.03.2023 17:56
Дано натуральное n. Найдите сумму кубов первых n натуральных чисел. На языке Python....
вика3855
06.04.2020 09:55
3 сор 6 класс 3 четверть по информатике скиньте если писали...
Sashenka585888
08.02.2020 09:58
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов в диапазоне от 0 0 до 23 23 , потом знак двоеточия, потом обязательно двузначное...
zachar3
22.01.2021 07:31
Старшеклассники заполняли анкету с во об экзаменах по выбору. Оказалось, что выбрали они информатику, физику и обществознание. В классе 38 учеников. Обществознание выбрал 21 ученик,...
pakipysi
30.06.2021 22:21
Ввод 1 6001 Вывод 1:40:01 Ввод 2 61 Вывод 0:01:01...
010Dasha010
24.01.2020 18:32
Var k,n,a:integer; begin readln(n, k); a:=k; while k (n/3) do begin k:=k+1; n:=n+1; end; writeln(k-a); end. Перевести этот код с PascalABC в Python 3...
Ответ:
ale2005171112
06.10.2020 12:45
Uses
graphABC;
const
W = 800;
H = 500;
function F(x: real): real;
begin
F := cos(x * x);
end;
var
x0, y0, x, y, xLeft, yLeft, xRight, yRight, n: integer;
a, b, fmin, fmax, x1, y1, mx, my, dx, dy, num: real;
i: byte;
s: string;
begin
SetWindowSize(W, H);
xLeft := 50;
yLeft := 50;
xRight := W - 50;
yRight := H - 50;
a := -2;b := 6;dx := 0.5;
fmin := -10;fmax := 20;dy := 2;
mx := (xRight - xLeft) / (b - a);
my := (yRight - yLeft) / (fmax - fmin);
x0 := trunc(abs(a) * mx) + xLeft;
y0 := yRight - trunc(abs(fmin) * my);
line(xLeft, y0, xRight + 10, y0);
line(x0, yLeft - 10, x0, yRight);
SetFontSize(12);
SetFontColor(clBlue);
TextOut(xRight + 20, y0 - 15, 'X');
TextOut(x0 - 10, yLeft - 30, 'Y');
SetFontSize(8);
SetFontColor(clRed);
n := round((b - a) / dx) + 1;
for i := 1 to n do
begin
num := a + (i - 1) * dx;
x := xLeft + trunc(mx * (num - a));
Line(x, y0 - 3, x, y0 + 3);
str(Num:0:1, s);
if abs(num) > 1E-15 then
TextOut(x - TextWidth(s) div 2, y0 + 10, s)
end;
n := round((fmax - fmin) / dy) + 1;
for i := 1 to n do
begin
num := fMin + (i - 1) * dy;
y := yRight - trunc(my * (num - fmin));
Line(x0 - 3, y, x0 + 3, y);
str(num:0:0, s);
if abs(num) > 1E-15 then
TextOut(x0 + 7, y - TextHeight(s) div 2, s)
end;
TextOut(x0 - 10, y0 + 10, '0');
x1 := a;
while x1 <= b do
begin
y1 := F(x1);
x := x0 + round(x1 * mx);
y := y0 - round(y1 * my);
if (y >= yLeft) and (y <= yRight) then SetPixel(x, y, clGreen);
x1 := x1 + 0.001
end
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота