galinaluchwaya666
22.03.2022 01:44

Нужна ) написать программу в python, которая запрашивает у пользователя имя файла со стихотворением и распечатывает строку с наибольшим количеством согласных букв.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
seva0311
06.10.2020 12:52
Python 3.6.1:

print('Введите путь к файлу: ')
f = open(input(),'r')
B = 'бвгджзклмнпрстфхцчшщ'
Max = 0
for S in f:
    k = 0
    for C in S.lower():
        if C in B:
            k+=1
    if k > Max:
        Max = k
        MaxS = S
print(MaxS)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота