DiDnteR
04.05.2020 07:25

Написать программу на языке паскаль, реализующую следующую : товары двух видов. запросить с клавиатуры для каждого товара цену, количество в начале рабочего дня и количество проданного товара (и одного и другого) за день. вывести выручку от продажи двух товаров за день.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ритка069
16.08.2020 08:47
Запрашивается цены товаров и их количество в начале рабочего дня.
Запрашивается количество проданного товара.
Выводится ответ.
Возможно, надо было запросить не кол-во проданного товара, а кол-во оставшегося товара, но я составил программу по условию. (если нужна будет другая, то отредактирую)

program tovar;
var t1,t2,p1,p2:integer;
    c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида было продано за день?');
ReadLn(p1);
WriteLn('сколько товаров второго вида было продано за день?');
ReadLn(p2);
s:=p1*c1+p2*c2;
WriteLn('Выручка за день ' ,s);
end.

/// Возник вопрос. Зачем спрашивать, сколько товаров было в начале рабочего дня, если эти данные не используются, вот я и решил составить программу, которая, возможно, требовалась

program tovar;
var t1,t2,p1,p2:integer;
    c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида осталось?');
ReadLn(p1);
WriteLn('сколько товаров второго вида осталось?');
ReadLn(p2);
s:=(t1-p1)*c1+(t2-p2)*c2;
if (t1-p1<0) or (t2-p2<0) then WriteLn('Внимание! Кол-во оставшихся товаров, больше чем кол-во товаров в начале рабочего дня. Проверьте правильность данных.');
WriteLn('Выручка за день ' ,s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота