veronikadasha8
27.06.2021 11:19

Напишите программу на языке паскаль! с клавиатуры вводится три четырёх значных числа. найти сумму нечётных цифр в наименьшем числе.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ijony
06.10.2020 13:38
Var
  a, b, c, sum: integer;

function min(x, y: integer): integer;
begin
  if(x > y) then result := y
  else result := x;
end;
 
begin
  sum := 0;
  read(a, b, c);
  a := min(a, min(b, c));
  while a > 0 do
  begin
    if(a mod 10 mod 2 <> 0) then sum := sum + a mod 10;
    a := a div 10;
  end;
  write(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота