Sadist702
06.06.2023 21:09

Нужно составить программу обработки данной строки, позволяющую выписать все знаки сравнения и все скобки, сохранив их последовательность

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
youngest1111
06.10.2020 13:58
Теперь уже PascalABC.Net 3.2
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
  if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
  end;
end.
Я надеюсь, <>=() - это все знаки, которые вы перечислили?
0,0(0 оценок)
Ответ:
dinara951211
06.10.2020 13:58
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadlnString('Введите строку:').MatchValues('[()=<>]').Println('')
end.

Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота