Ilana27
19.09.2021 17:02

Программы в паскале. 1)напишите программу,которая находит сумму,произведение и среднее арифметическое трёх целых чисел,введенных с клавиатуры.примеры: 4+5+7=16; 4*5*7=140; (4+5+7)/3=5.333. 2)напишите программу,которая вводит радиус и вычисляет его площадь и длину окружности.примеры: радиус 5; площ. и длин.окр. 78.540,31.416 3)напишите программу,которая вводит два целых числа,а и b(а

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Rube13454hill
06.10.2020 14:44
1)
var a,b,c:integer;
begin
readln(a,b,c);
writeln(a,'+',b,'+',c,' = ',a+b+c);
writeln(a,'*',b,'*',c,' = ',a*b*c);
writeln('(',a,'+',b,'+',c,')/3 = ',(a+b+c)/3:5:3);
end.

Пример:
4 5 7
4+5+7 = 16
4*5*7 = 140
(4+5+7)/3 = 5.333

2)
var r:integer;
begin
readln(r);
writeln('S = ',pi*r*r:5:3);
writeln('C = ',2*pi*r:5:3);
end.

Пример:
5
S = 78.540
C = 31.416

3)
var a,b,i:integer;
begin
readln(a,b);
for i:=1 to 5 do
 write(random(b-a+1)+a,' ');
end.

Пример:
0 100
8 1 86 54 60
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота