Nasib15
31.08.2021 10:16

С++ напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vipvikaviktoria
20.08.2020 22:10
#include <iostream>

int main()
{
    float x, y;
    float res = 1;
    std::cin >> x >> y;
    for (int i = 0; i < y; i++)
        res *= x;
    std::cout << res << std::endl;
}
0,0(0 оценок)
Ответ:
benslip13
20.08.2020 22:10
function Power(x,y:real):real;
{ (C) Puporev }
begin   if x=0 then     Power:=0  
else    
if x>0 then      
 Power:=exp(ln(x)*y)  
  else      
 Power:=-exp(ln(abs(x))*y);
end;
  var  x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота