Марьяша077
11.11.2022 02:22

Тема.организация циклов.программа c#. точно не уверен как делать. но мне надо составить программу для вычисления вот этого. y=sqrt ln(x^2-3x+2) при x=0.12.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SemenOr
06.10.2020 20:37
Using System;

class Program
{
public static void Main()
{
double x,y;
for (x = 0; x <= 12; x++)
        {
            y = Math.Sqrt(Math.Log(x*x-3*x+2));
            Console.WriteLine("x = {0}, y = {1}", x, y);
        }
        Console.ReadKey();
}
}

Результат:
x = 0, y = 0.832554611157698
x = 1, y = NaN
x = 2, y = NaN
x = 3, y = 0.832554611157698
x = 4, y = 1.33856619904585
x = 5, y = 1.57635866787606
x = 6, y = 1.73081838260229
x = 7, y = 1.84423354856758
x = 8, y = 1.93330536084794
x = 9, y = 2.00632791206601
x = 10, y = 2.06801018348945
x = 11, y = 2.1212754819519
x = 12, y = 2.16805912414593

PS. NaN - функцию невозможно вычислить при данном значении аргумента.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота