ZhenyaN123
10.12.2020 05:30

Решить хотя бы несколько из них . написать программу (c++) : а) вывести на экран первые n чисел ряда фибоначчи. б) найти нод n заданных с клавиатуры чисел. в) найти нок трех заданных чисел. г) задан прямоугольник с длинами сторон, выраженными целыми числами. из минимального количества квадратов его можно составить?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
АэлинкаМалинка
06.10.2020 23:45
А) Решение не совсем эффективно, но для школьного примера, то что нужно.
#include <iostream>
using namespace std;

unsigned fib(unsigned x)
{
    if (x == 0)
        return 0;
    if (x == 1 || x == 2)
        return 1;
    else if(x > 2)
        return fib(x - 1) + fib(x - 2);
}

int main()
{
    unsigned n = 0;
    cout << "How much numbers you want to print: " << endl;
    cin >> n;
    cout << "The Finonacci serie: " << endl;
    for(unsigned i = 0; i < n; ++i) {
      cout << fib(i) << " ";
    }
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота