Полина20351
18.06.2021 13:26

Составьте программу заполнения массива не используя клавиатуру, числами 1, -3, 5, -7, 9, -11, 13, -15. в питоне , если можно то не сильно сложно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЕлизабетклассD
07.10.2020 00:37
# coding: utf-8
list = []  # создаём пустой лист
flag = 0  # переменная, которая будет чередоваться
for i in range(1, 16, 2):  # диапазон от 1 до 15 с шагом в 2 числа
    if flag == 0:  # когда переменная равна 0 пишем положительное число
        list.append(i)
        flag = 1
    else:  # иначе отрицательное
        list.append(-i)
        flag = 0
print(list)  # выводим результат на экран



Первую строку можно не писать.



Код без комментариев:

list = []
flag = 0
for i in range(1, 16, 2):
    if flag == 0:
        list.append(i)
        flag = 1
    else:
        list.append(-i)
        flag = 0
print(list)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота