учеба6358
30.09.2020 21:36

Паскале делать 3. не про спиннеры саша совсем не любит спиннеры, поэтому он рисует в тетрадке . он взял тетрадный лист из n x m клеточек и пронумеровал все клетки различными числами. теперь ему стало интересно, сколько различных прямоугольников он может вырезать из жтого листа бумаги по границам клеточек. программа получает на вход два числа n и m размеры исходного листа. все числа - целые положительные,не превосходящие 75000. программа должна вывести одно число- количество прямоугольников, которые можно вырезать из данного листа бумаги(весь лист целиком также считается одним из возможных прямоугольников)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мижоп
07.10.2020 01:56
Посчитаем сколько всего узлов на этом листке:
у нас он N клеточек в высоту, значит всего в каждом столбике N+1 узел;
у нас он М клеточек в ширину, значит всего в каждой строчке М+1 узел.
Значит всего узлов (N+1)*(М+1).
Чтобы определьть прямоугольник, надо определить два узла в которых будут противоположные углы:
первый узел мы можем выбрать (N+1)*(М
второй узел мы можем выбрать N*М мы не можем выбрать тот столбик и тот ряд, в котором у нас стоит первый узел).
Тоэсть всего выбрать (N+1)*(М+1)*N*М, но это не так.
Рассмотрим весь лист как выбраный прямоугольник.
Пусть мы его выбрали так:
(0; 0),  (N+1; М+1).
Этот же прямоугольник мы считали, когда плучали с такими координатами:
1) (N+1; М+1),  (0; 0).
2) (N+1; 0),  (0; М+1).
3) (0; М+1),  (N+1; 0).
И так с каждым прямоугольником, тоэсть каждый прямоугольник мы считаем 4 раза, тоэсть конечная формула такова:
(N+1)*(М+1)*N*М / 4.
Осталось составить прогрмму, которая будет это вичислять.
С++:
#include <iostream>using namespace std;int main()
{
int N, M, k;
cin >> N >> M;
k = (N+1)*(M+1)*N*M / 4;
cout << k << endl;
return 0;
}

Pascal:
program Znanija;
var N, M, k:integer;
begin

read(N);
read(M);

k:=((N+1)*(M+1)*N*M) div 4;

writeln();
writeln(k);

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота