zugor55
18.11.2020 19:07

Написать программу в c++ найти все простые числа в заданном пользователем диапазоне [a; b].

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
uchikha2016
07.10.2020 03:11
#include <iostream>
#include <cmath>
using namespace std;
bool prost(int m){
int k = 0;
for (int i=2; i<=sqrt(m); i++)
if (m % i == 0) k++;
return k==0;
}

int main(){
    int a, b;
    cin >> a >> b;
    for (int i=a; i<=b; i++)
     if (prost(i)) cout << i << " ";
    return 0;
}

Пример:
5 20
5 7 11 13 17 19
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота