minimym22
26.10.2020 16:16

Составить программу на паскале. дан одномерный массив целых чисел из n элементов. найти и вывести номера элементов заканчивающихся цифрой 0.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
scfsdfddPenis
07.10.2020 03:17
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var s:=a.IndexesOf(x->x mod 10=0);
  if s.Count=0 then Writeln('Нет элементов, оканчивающихся на 0')
  else begin
    Write('Номера элементов, оканчивающихся на 0: ');
    s.Select(i->i+1).Println
    end
end.

Примеры
n= 12
-41 46 29 -13 -43 -21 48 43 41 -48 -19 -44
Нет элементов, оканчивающихся на 0

n= 16
37 -48 39 32 -6 21 -48 34 6 12 -10 -15 40 -36 46 26
Номера элементов, оканчивающихся на 0: 11 13
0,0(0 оценок)
Ответ:
znj93294znj93294
07.10.2020 03:17

const n = 10;

var a:array[1..n] of integer;

i:integer;

begin

  for i:=1 to n do readln(a[i]);

  writeln;

  for i:=1 to n do 

  if a[i] mod 10 = 0 then writeln(i);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота