Bekzhan20031
09.05.2023 13:33

Написать программу в с++, подсчитывающую количество символов в заданной строке. ответ должен быть развёрнутым.строку вводит пользователь. пример строка: мама мыла раму в строке: "мама мыла раму" символов: 14

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
armanpozitiva
07.10.2020 07:40
// Работает только на английском
// Количество символов для русского языка считает корректно, но вывод самой строки и работа со строкой не возможна.

#include <bits/stdc++.h>

using namespace std;

int main(){
setlocale(LC_ALL, "Russian");
 char s[1000]; int ans = 0;
 cin.getline(s,1000, '\n');
 string s1 = string(s);
 cout << "Строка: " << s << endl;
 cout << "В строке: <<" << s1 << ">> ";
 cout << s1.length() << " символов";
}
Пример:
For my heart
Строка: For my heart
В строке: <<For my heart>> 12 символов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота