flamerplay123
26.04.2022 21:02

Написать программу при поступлении в вуз абитуриенты, получившие “2” на первом экзамене, ко второму не допускаются. в массиве записаны все оценки экзаменующихся полученные на первом экзамене. подсчитать сколько студентов сдали первый экзамен на “5”, на “4”, на “3”, и сколько не допущено ко второму экзамену.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Annkot22
07.10.2020 07:54
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),2,5); a.Println;
  var b:=a.GroupBy(t->t).Select(t->(t.Key,t.Count)).OrderBy(t->t[0])
      .Select(t->t[1]).ToArray;
  Writeln('Сдано на 5: ',b[3]);
  Writeln('Сдано на 4: ',b[2]);
  Writeln('Сдано на 3: ',b[1]);
  Writeln('Не допущено: ',b[0])
end.

Пример
n= 20
4 4 3 5 4 5 2 4 4 4 5 4 3 3 4 2 3 2 2 2
Сдано на 5: 3
Сдано на 4: 8
Сдано на 3: 4
Не допущено: 5

Написать программу при поступлении в вуз абитуриенты, получившие “2” на первом экзамене, ко второму
0,0(0 оценок)
Ответ:
Мила20011
07.10.2020 07:54
Uses crt;var a:array [1..99999] of integer;i,n,k,l,p,o: integer;beginwriteln ('vvedite kol-vo ychenikov');readln (n);for i:=1 to n do beginwriteln ('vvedite osenky',' ',i,' ','ychenika');readln(a[i]);if a[i]=2 then k:=k+1;if a[i]=3 then l:=l+1;if a[i]=4 then o:=o+1;if a[i]=5 then p:=p+1;end;if k<2 then writeln ('ne dopyshen',' ',k,' ', 'ychenik');if k>=2 then writeln ('ne dopysheno',' ',k,' ', 'ychenika');writeln ('kol-vo 3 -',' ',l);writeln ('kol-vo 4 -',' ',o);writeln ('kol-vo 5 -',' ',p);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота