bozenka20042004
18.12.2020 18:07

Дан массив а[10]. найти мах элемент среди элементов, стоящих на чётных местах и найденным значением заменить все элементы массива а, кратные 3. преобразованный массив вывести на экран. напишите программу на языке паскаль, !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Котёнок0007
07.10.2020 09:45
Const
  CSize = 10;

var
  m: array[1..CSize] of integer;

begin
  randomize();
  var max := -(MaxInt);
  write('Исходный массив: ');
  for var i := 1 to CSize do
  begin
    m[i] := random(100) + 1;
    if (i mod 2 = 0) and (m[i] > max) then max := m[i];
    write(m[i], ' ')
  end;
  write(NewLine, 'Преобразованный массив: ');
  for var i := 1 to CSize do
  begin
    if m[i] mod 3 = 0 then m[i] := max;
    write(m[i], ' ')
  end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота