ssjjd
07.06.2021 23:04

Дан массив 20 целых, диапазон от -15 до +20 найти мин элемент и сумму кратных 3( написать программу pascal )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dianahohlova
07.10.2020 09:48
Program n1;
const n=20;
var a: array [1..n] of integer;
i,min,sum:integer;
begin
randomize;
sum:=0;
write('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(36)-15;
write(a[i],' ');
if a[i] mod 3=0 then sum:=sum+a[i];
end;
writeln;
min:=a[1];
for i:=1 to n do if min>a[i] then min:=a[i];
writeln('минимальный элемент:', min);
writeln('сумма кратных трем: ',sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота