pilizaveta13
22.11.2022 06:50

Написать программу в pascal. задан двумерный массив c из 3-х строк и 5-и столбцов. составить программу, которая вычисляет произведение всех элементов массива. затем организовать новый массив с, в котором значения элементов, лежащих на главной диагонали, равны 1, а остальные элементы равны квадрату соответствующих элементов исходного массива с.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sarah205682
16.08.2020 15:07
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var c:=MatrRandom(3,5,-9,9);
  c.Println(4); Writeln(4*c.ColCount*'-');
  Writeln('Произведение элементов: ',
      c.ElementsByRow.Aggregate(int64(1),(x,y)->x*y));
  Writeln('*** Массив-результат ***');
  c.Transform(t->t*t);
  for var i:=0 to c.RowCount-1 do c[i,i]:=1;
  c.Println(4)
end.

Пример
*** Исходный массив ***
  -7  -3   4  -1  -5
   9   1   9   2   4
  -3  -3  -1  -4  -8

Произведение элементов: -78382080
*** Массив-результат ***
   1   9  16   1  25
  81   1  81   4  16
   9   9   1  16  64
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота